Error 422 smpt port must be string after update

Hi, since today after installing the latest update, I get the following error when I try to save my advanced settings (in German: “Erweiterte Einstellungen” (e.g., invoice design, etc.):

422: The given data was invalid.
• The smtp port must be a string.

I have not changed anything.

I am now using: v5.8.26-C155

In the storage/logs/laravel.log, I see the following error in red:

[2024-02-18 14:47:06] production.ERROR: Undefined array key “80xxxxx” {“userId”:1,“exception”:"[object] (ErrorException(code: 0): Undefined array key "80xxxx" at /xxx/billing.xxx.com/invoiceninja/app/Models/CompanyGateway.php:167)

I get the error on any device/system.

Anyone else who can observe this behavior? Any idea how I can fix this?

Hi,

Sorry for the trouble, we’ll make sure this is corrected in the next release.

In the meantime you should be able to use either the React web app or the desktop app instead.

1 Like

Thank you so much for looking into it! The React web app nor the (Linux) Desktop version did not solve the issue. I still get the same error. But it is not crucial as all other functions work, it is only the settings. THANKS!