English and Euro not available in settings

I am a new user and installed invoiceninja with docker.
In System > Localization I want to select Euro and English.
However, it seems I am only able to see/select a subset of the options.

  • Cambodian riel
  • Cuban Peso
  • Gambia Dalasi
  • Malawi Kwacha
  • Paraguayan Guarani
  • Vanuatu Vatu
  • Zimbabwean Dollar
  • texts.currency_cayman_island_dollar


  • Arabic
  • Estonian
  • Latvian
  • Persian
  • Russian (Russia)
  • Serbian
  • Slovak

I tested this on my local arch machine and a remote Debian machine.

Also when I select one of the listed currencies, the settings page gets grayed out and there is no way of returning


Thanks for reporting this, do you see all of the records if you check the database directly?

@david any thoughts, do you want to update demo or staging?

I did not expect such a quick response. I’m not familiar with databases. How should I check the database directly?

One option would be using phpMyAdmin, it’s supported by many web hosts.

Otherwise you can wait for us to debug the problem.

I have not been able to connect to the database yet since I haven’t found any tools by my vps host. However, while scrolling through the settings I found that I was reaching the memory limit in my plan. This might be the reason for the application behaving in an unexpected way

It’s possible. Another user reported the same issue on Slack so I think this particular issue may be a bug in the app.




should resolve this issue.

That worked for me!
Could you explain what this command did?


/update does two things:

  1. Rebuilds the cache (where we store static data such as countries / currencies)
  2. Rebuilds the laravel framework configuration cache.
1 Like