Empty currency in the payment and profit/loss report

I’ve been trying to find other people mentioning this but haven’t been able to find anything yet so hopefully someone here can help.

When running the payment or profit/loss report, expenses seems fine, the currently section of the report is split into two one line for “British Pound” and one line which is empty.

I’ve tried resaving my currently settings within the system, client and also resaving the payments in case there’s an issue there but still not able to get it all combined into “British Pound”.

I’m not using any currency conversion features, that I’m aware of, so not sure where to go with this one.

Anyone have any ideas?

Screenshot here for reference: report screenshots

1 Like


Is it possible you have expenses in your account without the currency set?

@david can you please check that the API set the company currency for the expense if none is set.

Expenses look to be okay, sorry, forgot to add an example for those.

I believe its payments having missing currency but I don’t see a way to add a currency to a payment.

I’ve added a screenshot of the expense report to the folder I shared in the link in my original post.

1 Like


expenses have a currency force set on creation

Are you able to check the database directly to see if all expenses have the currency_id field set?

To clarify as with my reply above expenses are fine. This seems to be affecting payments. The majority of which were created via the invoice make payment action.

Do payments have the same column can verify thosee if so.

There is a currency_id field in the payments table

@david it’s worth noting in most places in the app we use payment.client.currency_id however in these two reports we use payment.currency_id. It may help explain the problem.

:thinking: I’ve checked the database and the majority of the payments have a currency_id of 0 which seems to confirm the report.

Is this maybe a bug with the action when entering a payment from the invoice. Since IIRC it doesn’t provide you with a form and just creates the payment in the background. I also don’t see a way in-app to edit the currency for a payment.

For bookkeeping reasons I have moved to a bookkeeping platform with invoicing built in, purely because my basic needs don’t warrant complicated invoice systems and it was more for bookkeeping. I do have my instance running still though so happy to provide any debug info that you need.