Emails not showing in sent items

Invoices are sent & received but not showing up in my sent items.


Do you mean the sent folder of your email account?


Yes, when I check sent items of email accounts@??? shows no sent emails.

It may help to send an email to yourself to confirm which email account is being used.

@david do you have any suggestions?

I’ve tested & emails are sent from correct email & received.
I do receive an email sent notification in my inbox.
But no sent email in sent items of the account being used to send invoices via email.


Unsure, it could be that your mailserver does not store these when sent from an application.

I’ll test another mailserver with a different host later.

Same result, anyone having similar issue?

Seems no one has similar issue.
Have just added accounts email to bcc when sending as a work around.

hello there.

I have the same problem here.

I had another application in PHP and it worked, I needed to put a code to work.

Here, it doesn’t work.

Same here.
It would be helpful if the emails were saved on the server.
I currently BCC myself to keep a record and confirm sending, but it would be good if that worked more like an regular email account.

Good to know i’m not alone on this issue

Hello @hillel

Do you have any idea what we can do?

I have this code, I used it in my old app…

$mail_string = $mail->getSentMIMEMessage();
$ImapStream = imap_open("{}Sent", $info_email['email_sender'], $info_email['password']) or die('Cannot connect: ' . print_r(imap_errors(), true));
imap_append($ImapStream, '{}Sent', $mail_string) or die('Cannot copy: ' . print_r(imap_errors(), true));

Do you know if we can update a file with this kind of code to make it work?

@david can you please advise?

Hello there.

No advise for this matter?

There are only settings for SMTP? How should it store in your IMAP folder?

I don’t know how this is handled on hosted InvoiceNinja, but self-hosted seems to support SMTP only. So if you would like to have a prove that your emails have been sent, you could enable BCC like already mentioned: