Email template translation


The following I want to be translated into the language of each client …

‘quote_message’ => ‘To view your quote for :amount, click the link below.’,
‘invoice_message’ => ‘To view your invoice for :amount, click the link below.’,

How can I do that?

Thank you

If you use the default email templates the body/subject should be translated.

If you want to use custom body message one option would be to store the changes in the respective resources/(lang)/texts.php file.

Hi Again
The subject is translated normally but the body remains in English.
More specifically, the only thing that does not translate is this message…
“To view your invoice for €5,00, click the button below.”

Maybe the strings need to be translated on Transifex?

I have tried it in different languages and I see that it is the same.
In the link above I can see that the languages I tried are 100% (Greek ,Dutch).
Also in texts.php file I see that this string is normally translated.

I’m not sure, if you’re using the default template it should be translated.

I’d suggest trying to click ‘reset’ then ‘save’ on Settings > Templates & Reminders

Yes I did that …But it does the same thing again

Which languages are selected for the account and client?

My account is in English and I have tried a Greek-language client and one with Dutch…

I’m not sure, I’ll try to replicate the problem.

Hi Hillel

The problem is resolved.
I tried it /?clear_cache=true and everything is working properly.
Thank you for everything.

Great to hear, thanks for letting us know!