Email payment receipt to the client

Hi All,

Edit: Running IN in docker/Linux with version v5.1.55-C47

I’ve found something that doesn’t seem to work logically.

1. When creating a payment for an invoice AND I don’t want to email the client of this, I turn off the “Email payment receipt to the client” radio button:

image

2. Because I have IN bcc me on emails, I see that IN is in fact sending out these emails to the client:

This appears to be doing the opposite of what I expect. If this something I have to set in IN, please let me know. Maybe it’s a bug?

2 Likes

I found another, possibly overlapping setting called “Manual Payment Email” in Settings → Company Details → Defaults that may overrule things. I’ll test and see if it does.

Hi,

Thanks for reporting this!

@dave any thoughts?

Seems like I’ve got the same issue (I’m using v 5.2.7).
It doesn’t matter if the radio button Send Email is activated or not. IN will always send a payment receipt to the client.

Is this for online payments or manual payments?

cc @david

@meisterkeks

I can’t recreate this issue. for either manual or online payments.

It’s for manual payments.

I did further investigation in conjunction with the default setting in Settings -> Company Details -> Defaults -> Manual Payment Email.

  • With default setting off, the radio button Send Email is inactive and no email is sent (as expected).
  • With default setting on, the radio button Send Email is active and email is sent as expected.
  • But when default setting is on and I deselect Send Email, the mail is sent nevertheless.
1 Like

Thanks for the details, that’s very helpful!

I’ll do some testing to check if it’s a problem with the backend or frontend.

@meisterkeks I vaguely remember this one. Right now, all email options are off in the payment screen, and no emails are sent on payments:
image

This is likely due to how I’ve set the options in Settings → Company Details → Defaults

In addition, under Settings → Email Settings → BCC Email - I set that to my own address so I see every message that goes out. I’m not sure I - even now - trust the system. I’ve had a number of cases where errant messages go out and the customer is like (huh?).

Thanks for your contribution.

I’ve set the same settings.

I am checking in a fix for this.

3 Likes

Does the stable version already contain the fix?
I’ve got a similar issue today with v.5.2.13.

With default setting off, the radio button Send Email is inactive, but a receipt is still send to the customer.