E-mail template with incorrect URL - http://in.localhost:8003/storage/

Where is this URL coming from???

“in.localhost:8003” is not defined ANYWHERE (that I know of) in my configuration so where is it coming from?

It’s causing an ugly broken link at the top of any invoice e-mails I send out.

It’s trying to include a link to my logo but why is it using in.localhost:8003 instead of the APP_URL I defined. If it used APP_URL instead of “in.localhost:8003”, it would work fine and everything would be great. But why isn’t it? Is there some other file I need to edit? Something in the admin portal I haven’t found yet?

I’m running the self-hosted Dockerfile solution which I installed by following the instructions at GitHub - invoiceninja/dockerfiles: Docker files for Invoice Ninja. It’s installed on an Ubuntu 22.04 VM on my home network but I’ve made it accessible via a real domain name with letsencrypt certificates and port forwarding.

The “about” link says I’m running “v14.04.2024.1” which is strange because I’ve only heard about versions 4 or 5 and thought I was runing v5?

I access the server with https://ninja.mydomain.com

The APP_URL in the ENV file is set to http:\ninja.mydomain.com

In my dockerfile, under “server:”, “app:” and “db:”, I have:
- “in5.localhost:”

I’ve seen some similar posts to this - but none exactly the same - and none with solutions.
If there is a solution somewhere, could someone please send me the link?

Update. I’ve found 2 other spots that use that same link with in.localhost:8003

  • The very top left corner of the admin portal
  • The Settings->Logo page
    Both of those areas also try to display my logo and they also use that same incorrect server name and port.

UPDATE: On a whim, while waiting for a response to this post, I decided to try re-uploading my logo - and for some reason that fixed everything…! After re-uploading it, ALL three of those incorrect url’s are now correctly using the real, actual domain name! I’m not sure why this fixed it - but it did and now I’m happy.