Download PDF not working

After update to 2.9.1 and now trying 2.9.3 I am not able to download PDF’s from Edit Invoice. Clicking on the button does nothing except showing that it has been clicked on. This seems to also be affecting clients but I cannot back this up, just a couple of complaints that they cannot open the invoices.

I have tried on Firefox and on Chromium browsers on my system. Can anyone give me some pointers?


Are there any errors in the browser console?

Uncaught ReferenceError: logoImages is not defined at GetPdfMake (pdf.pdfmake.js:103) at generatePDF (script.js:31) at onDownloadClick (edit:2827) at HTMLButtonElement.onclick (edit:1446) GetPdfMake @ pdf.pdfmake.js:103 generatePDF @ script.js:31 onDownloadClick @ edit:2827 onclick @ edit:1446

Thanks! That’s helpful but I’m not able to replicate the problem.

If you can email a test invoice to I can try to debug it further.

I’m not sure if it’s related, but I also have a problem emailing invoices. The email dialog comes up and asked for confirm, but I am not receiving an invoice. The test emails on system settings work. This also stops me being able to send you a test email unless there is another way to generate and email an invoice?


When viewed as client I can download PDF. It is only from Edit Invoice screen.

These could be the same problem, if you’ve enabled ‘Attach PDF to emails’ it would fail to send the email if it fails to create the PDF.

Try right-clicking the page, selecting ‘View source’ and then searching for this line:

Is this the Edit Invoice page? I tried right clicking here and searching source, but did not find the line.

I also tried disabling send invoice in the settings and it does now work sending the emails, so it looks like the same problem.

Yes, it should be on that page.

Compare your version of resources/views/invoices/pdf.blade.php against the link above.

I compared both with diff and they are identical files

I’m not sure, maybe try running

sudo php artisan view:clear

Also, if you haven’t already try loading /update

Tried this, no change
php artisan view:clear

How can I run /update manually?

Do I need to run through

composer dump-autoload --optimize
php artisan optimize --force
php artisan migrate
php artisan db:seed --class=UpdateSeeder


You load /update in your browser. ie, (or /public/update).

Are there other errors in your log in storage/logs/laravel-error.log

Thanks, ran update, no change.

There are no errors for 2017 in the log

Can you email the ‘view source’ content of the edit page to

On it’s way

Thanks, I may see the problem.

Do you have ‘live preview’ disabled on /settings/account_management

Yes I do and confirm download PDF is working when I enable it.

Do I need to keep it enabled from now on?

Yeah, it looks like disabling it is breaking the download button.

In our next release if the preview is disabled we’ll hide the download button but you can get to it by clicking ‘View as recipient’.

OK. Nice to have it working again and thank you so much for your help today.