Document upload broken in v2.7.0

I upgraded to v2.7.0 and noticed that the document upload is not working anymore.

When I upload a png, I get the checkmark that it succeeded. But if I than save the invoice or quote and go back to the documents tab, the thumbnail is broken and when I click on it I get “Whoops, looks like something went wrong.”

If you need further details, I’m happy to provide them.

Thanks for letting us know, I’m looking into it.

We’ll include a fix with our next release, here’s the change if you want to patch your instance.

Patched it, now it works again. Thanks!

Extra note: when you drag&drop multiple files (PNG in my case), at least 1 file will fail and sometimes need to delete and re-upload. Also experienced this in the previous version.

Thanks for letting us know, we’ll try to fix it in a future release.

I also noticed that jpg files cannot be uploaded. Occurs in all the modules.

Version 2.7.1
JPEG size 2.4MB

Can you check if there are any details in storage/logs/laravel-error.log

Also, can you try with a different/smaller JPEG file.

I found this error after uploading a file of approx 2,5MB:

[2016-09-20 14:00:06] production.ERROR: exception 'Symfony\Component\Debug\Exception\FatalErrorException' with message 'Allowed memory size of 134217728 bytes exhausted (tried to allocate 16128 bytes)' in D:\XAMPP\htdocs\invoiceninja\vendor\intervention\image\src\Intervention\Image\Gd\Decoder.php:119 Stack trace: #0 {main} [] []

Smaller JPG of 400kB is no problem.

Strange that a relatively small file would use up so much memory.

You may be able to workaround it by increasing your PHP memory limit.

I increased the PHP memory limit and tried JPEG’s of 2MB to 5MB, works now.


Great to hear, thanks for letting us know!