did something change recently with currency formatting?

I have a couple of French clients that I bill in Euros, and a month ago (running a slightly earlier version, 4.4.1 of invoice ninja) the amount was properly represented to them everywhere in the Invoice Ninja interface and on the PDF invoice as:

1.400,00 € (that is one thousand four hundred euros and zero euro cents, with the euro symbol after a space and at the end)

But today I issued a new invoice to my other French client with the same settings (Euro currency, French langage) while on updated 4.4.3 and it is suddenly looking like this everywhere:

€1,600.00 (that is one thousand six hundred euros and zero euro cents, with the euro symbol at the beginning with no space after)

Is there some reason this might have changed or some way to set the proper formatting for my French clients?


I’m not sure it’s likely that something changed in the app, minor releases should only include bug fixes.

Is it possible the country isn’t set for the client? We use the country to determine the localization settings.

The country is definitely set. Can you tell me where the currency formatting settings for each language are stored? I can check there and manually edit them I guess. Thanks!

We set the per country settings here, it looks like the app should already be placing the currency symbol at the end for French clients.


Well this is very strange. In each of my French clients I have currency dropdown set to “Euro” and Language set to “French” (not “French - Canada” btw) and in every invoice I create for any of them, the formatting is not what it what a month ago. The currency symbol is placed before the amount, and the separators are wrong (comma and period should be reversed). Any other ideas? I have verified that my CountriesSeeder.php file looks like yours linked to above btw.

You said it in your earlier comment but not this one, is the county (not language) set to France?

ah!!! that was it! I had the language and currency set, but not the COUNTRY in the address fields part. THANK YOU!! (And sorry to be such an idiot :))

Glad to hear it’s working!

I’m a new french user of InvoiceNinja.
I have clients in Martinique.
Martinique and Guadeloupe are French islands.
But, the first client I just recorded in Martinique is left with the sign € before the amount rather than after …

I tried to add these lines to the CountriesSeeder.php file:
‘MQ’ => [// Martinique
‘swap_postal_code’ => true,
‘swap_currency_symbol’ => true,

But, that does not work.
Can you tell me how to correctly display the amounts for my clients in Martinique?

Thank you in advance. and sorry for my bad english…

Is the client’s country set?

Yes, set : Martinique

For my french clients, no problem with postal code and currency symbol

Try loading /update (or /public/update) for the change to CountriesSeeder to be applied.

Yes ! Thanks a lot !
It works.
Thank you for your responsiveness and especially this day of Eve. I did not expect so much!