Default invoice design is not applied to new invoices

For some reason, invoice design set under Settings->Advanced Settings->Invoice Design (Creative) is not applied to newly created invoices. I haven’t made any changes to the design itself, but for some reason, newly created invoices, when saved, use Business design template. This happens when I access the system both from the browser and from the app on Mac, but not on the iOS app on my phone. I tried refreshing data and clearing cache, but nothing helps.
I’m running v5.5.70-C106 in docker.


is it possible you’ve overriden the default design at the client or group level?


You’re the man @hillel! :slight_smile:
I don’t even remember doing that, I actually did check if there were any settings under the client before, but I used ‘Edit Client’ instead of ‘Settings’ under the Clients menu. This is a little bit misleading, imho, as I would expect that ‘Edit Client’ and ‘Settings’ would have the same endpoint, but that’s just me.
I migrated from v4 to v5 yesterday and this was the only major issue that I was having with the new version. Maybe this is something that got migrated from v4?
I did have to disable the PDF preview under invoices as it gets stuck in a loop quite often, but when I click on ‘View PDF’ under an invoice, it works well. Is this a known issue, or is it just me? I’m planning on migrating this setup to either Kubernetes or to Docker Swarm in the near future, so hopefully that works out well.

The ‘settings’ feature is new for v5, it enables you to override many company settings at the client or group level.

I’m not sure abut the PDF issue, do you see any errors in the browser console?

No errors as such, just a bunch of timeouts. As I’m running it in docker, I will try to reserve some resources to it to see how it behaves.