Customizing invoice design > font changes not applied

I am working on a custom invoice design.

The Primary and Secondary font selectors in Settings > Advanced Settings > Invoice Design don’t appear to actually change the font. I have tried over 10 different fonts in each one - fonts that are significantly different, but my preview remains unchanged - even after saving after each font change.

Am I doing something wrong?

Thank you.



Are you using a standard design or a custom design?

Also, do you see the same problem here:

I have tried both my Custom Design as well as several of the standard designs. The behavior is the same.

I just tried on the demo site as well. The default fonts are Roboto. I changed Primary to “Aquafina Script” and Secondary to “Alex Brush”. I then clicked “Save”. I saw the contents of the preview refresh/redraw, but the fonts did not change.

@david do you have any suggestions?

Also - I’m not sure if this would actually work anyway, but I tried hardcoding the @import command to a specific font, just to see if anything happened. I replaced the Includes @import:

@import url($font_url);

with this:

@import url('');

and after saving there was still no change to the preview - even after closing out and going back in.

Ok - suddenly this morning it is working as expected. I’m doing exactly the same thing as yesterday. I wonder if something was being cached? Anyway - I’m good for now.

Glad to hear it, thanks for the update!

I use a custom font which i uploaded into the public/fonts directory. In order for it to work properly i had to add the following to my server-config

location /fonts/ {
	add_header Access-Control-Allow-Origin *;

I don’t realy understand why - as it’s all under the same domain.
Maybe the external pdf service is causing problems without this.
But even the html preview wouldn’t work without it.

1 Like