Customers Unable to Pay Invoices

Hi Hillel

Since the billing system seems incapable of profucing PDFs that can be read I disabled this feature

I have also disabled the password feature mso users can simply open the invoice in the portal and pay but now when they click “Pay Now” the system just hangs.

Two clients have had the same issue today alone, here’s a message from one of them:

I’ve tried several times over the last few days to make payment of this invoice using the pay now option on the portal. It keeps hanging once I press the pay button and won’t progress further. I have now given up and paid by bank transfer.

Thoughts on how I might resolve this as it’d be quite nice to actually allow people to pay since they cannot even receive an invoice attached now.

Have you checked the logs for any errors?

Thanks for the quick response Hillel

Please point me to the file(s) and I’ll take a quick look.


I don’t see anything relating to the bill payment UI, just this:
[2019-01-17 06:57:05] production.ERROR: PhantomJS - Failed to load File does not exist or is not executable: /public_html/phantomjs-2.1.1-linux-x86_64/bin/phantomjs {“context”:“PHP”,“user_id”:1,“account_id”:“1”,“user_name”:“XXXXXX”,“method”:“PUT”,“user_agent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0”,“locale”:“en”,“ip”:“XXXXXX”,“count”:1,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”,“url”:“invoices/1738”} []

I’d suggest using test mode and checking for any errors in the browser console when trying to pay an invoice.

OK, I can give that a try. How do I put the site into test mode please…?

You can enable test mode by clicking the gateway on Settings > Online Payments

Thanks Hillel

I went to the page in question and could not see this option so I then opened the Stripe gateway and again no option was available to put it into test mode.

To enable test mode with Stripe you need to use Stripe’s test API keys

I tried this just a moment ago and the page STILL hangs when I click the “Pay now” button:

I then switched to the live credentials for Stripe and the same happened.

When I opened up the console I saw this:

Thanks for the screenshot!

You should be able to fix it by enabling the billing address in the payment gateway settings.

We’re working on a release later today which will include a fix.

Thanks Hillel

Do you mean I should enable this option…?

I think you did.

I changed that option and it seems to work with a test card so will wait and see what happens with the next invoice payments.

That is correct