Custom fields for tasks are not completely implemented ($task.task1_label)

Hi @hillel,

in latest 5.1.26 I am able to activate the task custom fields Custom 1–4.

I expected to have the same options like in custom fields for products, but the option is missing.

This leads into empty columns in the PDF invoice:

I’d planned to define a sort of Task Categories like “Category” as Dropdown-List “Conception, Creation, Design, Deploymens …”, but the option is missing in custom fields, altough everything seems to be implemented in the task-view.

Is this Custom field reserved for V4 migrations, or is it too early (maybee available in the v5-develop branch). Do you have any idea?


Thanks for reporting this, the settings are missing. I’ll make sure they’re added in the next release.

@ben thoughts on the labels?

Thanks for submission. @hillel I’ve added this to develop backlog :+1:

1 Like

Hello @hillel,

after a fresh test install of v5.1.31-C44 I can confirm that the custom task fields implementation is far more operational than in prior versions.

When I define this:

The column shows the right content, but not the name of the custom field. I’d expected in my example “Leistungsart”. This is also a issue in over views, where not the name but “custom 1, 2…” is shown as column title.

If a render an invoice, where I set the task column like this:

The results is rendered like this (Plain Design, but same in other templates):

If I switch to empty column hide:

Bildschirmfoto 2021-03-23 um 17.12.28

The task section renders like this:

Can you reproduce this behaviour?


Thanks for the feedback!

We’ll look into showing the custom labels.

@ben any thoughts on the PDF issue?

Thanks for reporting this, I added this to my back log, will let you know more about it soon (I have to replicate it first).

Hey there, both issues have been fixed & they’ll be available in the next update. Thanks for reporting this :+1:

Hi @ben,

I am on v5.1.40-C45 fresh test install and company. I can can confirm the template formatting is working for both options: empty column show/hide.

There is still an issue:

I configured a custom field for task like here:

Added some tasks – all with set custom field – no empty ones.

By the way: The column title is not named properly after its task filed name 1. Operating with a column “Custom 1” is not self-explaining at forces users to guess, what was meant.

In Invoice Design I set up like this:

When I do an “Invoice Project” I discover that the columns are not corresponding to the task columns set in Invoice Design (here should show up “custom task 1” instead of “Item”, or is that meant for an other purpose?)

The PDF has correct Column Titles but the Custom Column is empty when “show empty”:

or disappears completely if “hide empty” is selected – although there are no empty custom task fields.

Can you please investigate once more in that scenario?

For PDF:

If I am following well, the behaviour is correct? If “Empty columns” is set to Show, it’s gonna show custom columns, if it’s “Hide” it’s gonna hide, can you please confirm that part is good?

cc @hillel for admin portal changes.

hi @ben, hi @hillel,

I try to subsummerize quickly what happens:
– I use Custom Field 1 for Task as shown above
– In Invoice Design I add Custom Field 1 into Task Columns
– I do a Invoice Project from Project View. I does not see the Custom Task 1 Column in Edit Invoice View, altough all Task Entries have selected Custom Task Entries (see Screenshot). Instead I see an Item Column.
– I save Invoice and the PDF is in both ways wrong:
a. When set to hide empty columns the Custom Task 1 Column does not show off, but it should because it contains data (see sample Task data screenshot).
b. When set to show empty columns it shows correctly the Custom Task 1 column but no data.

What I am trying to achieve is some sort of workarround for a behaviour I issued here as a Feature Idea