CRON Jobs Not Working Correctly


I’ve noticed that the CRON jobs I have setup have stopped working. To be more specific, this task:
php /home/XXX MY ACCOUNT NAME XXX/public_html/artisan ninja:send-invoices

Is not generating invoices.

The reminder CRON appears to be working though:
php /home/XXX MY ACCOUNT NAME XXX/public_html/artisan ninja:send-reminders

Very odd. Any suggestions…?

After checking, it seems the “Start Date” of the recurring invoices that were due to go out is now blank. COuld this be the issue…?

I tried to force a send by opening one and clicking send invoice but I got an error saying it’s not due to send.

If the start date is blank the invoice wouldn’t be sent.

I know. But the start date WAS NOT blank. These are recurring invoices that have run previously (some for months and months) so I suspect the start date was blanked following a recent update. Just a thought…

Not sure… if you can reproduce the problem I’m happy to look into it.

Here’s an example…

I have a client who has a recurring invoice that to all intents and purposes APPEARS as though it will be produced tomorrow:

But when I open the invoice I see this:

Thanks for the screenshots! It may be a display issue related to the date format.

  • Are you using the latest version of the app
  • Does changing the date format help

I’m not sure that will help to be honest as this problem has clearly been there a while.

Here’s an example.

But when I open the recurring invoice there’s no date in the “Start Date” field. When I add one I get this message:

And yet other clients appear to be OK.

I’m confused.

If you could please answer these questions it will help me know where to look next…

– Are you using the latest version of the app
– Does changing the date format help

Hi Hillel

The version is slightly out as the updates are minor.

I haven’t changed the date format in years so I wouldn’t know if it helps, sorry.

Something I find REALLY odd Hillel is that some of the recurring invoices are working OK, even though they do not appear to have a start date in therm when you open them.

I tried changing the date format (found it) and no joy.

The latest self host version is v4.5.1.

FYI… we hope to release v4.5.2 later today.

I’ll await that and then update, thanks.