CRON in v5 not working

I have a new instance of IN v5 on a dedicated server running CentOS Web Panel that I can not get the CRONS to work. I also have another instance of IN v4 running on the same machine where the CRONS have been working great for years. I thought I could use the same CRON code but just change the domain/location and everything would work. Example of what is working in IN v4…

0 * * * * php /home/username/ ninja:send-invoices

Does v5 not use this type of code? I figured I could change the path to the new domain and CRONS would work? Am I missing something?

I also tried…

0 * * * * cd /home/newusername/ && php artisan schedule:run >> /dev/null 2>&1

Any ideas of what Im doing wrong here?


Have you seen the info here:

The cron job in v5 needs to run every minute. You should replace the “0” at the beginning of the line with a “*”. (After that it takes one UTC midnight pass-through for the red triangle to disappear.)

1 Like

Ok I set the CRON to

* * * * * cd /home/newusername/ && php artisan schedule:run >> /dev/null 2>&1

I added the star at the beginning so it runs every minute. That seemed to have worked to get rid of the error in the GUI but now none of my re-curing invoices seem to be sent out. They are stuck on “Pending” and not sending.

If the cron was enabled after the send date then you’ll need to adjust the recurring invoice.

It seems to be working now. Thank you for the help!