Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.1.2"

I’m on the latest version may a few minor releases behind. I have not touched my PHP version either which is at 8.2. I’m now getting a random PHP version error. I have tried going back to 8.1 no luck and went back to the original 8.2 with no luck. Can you please assist?


I’m not sure, the error strongly implies that the problem is the PHP version.

You may want to run php -v and setup a phpinfo page to check.

[~]# php -v
PHP 8.2.16 (cli) (built: Feb 21 2024 04:21:23) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.2.16, Copyright (c) Zend Technologies
with Zend OPcache v8.2.16, Copyright (c), by Zend Technologies

In other cases of this error in the forum the problem was that a different version of PHP was being used even though the CLI said 8.2.