Cloudways Install - PDF, SMTP, API

Wanted to see if anyone has successfully installed v.5.0.43-C37 on Digital Ocean (via Cloudways).

I have the app up and running but can’t seem to get the following to work:

  1. PDF - this seems to be a common issue here. I’ve looked at several posts but don’t know if I have found the solution. Anyone who’s had success on Cloudways I would appreciate some assistance.

  2. SMTP - I’ve tried and tried to connect using Sendinblue. I’m certainly willing to try another (like Postmark) but I don’t understand why when I put in the right credentials no email gets sent. The application states that the email is sent but it never reaches my inbox nor does it show up in the sendinblue logs. I emailed their support to see if I was missing something, made a modification, but still nothing.

  3. API - I’m trying to create an API connection using Integromat. I’ve created the token, used the correct URL but it will not verify. Sent an email to their support and they replied, “we have investigated this matter and we can see that we got this response: 403: API requires a pro plan.” I understood that the self-hosted version was the pro version with the exception of removing the IN branding.

I hope I’m close here as I really like what I see but there appears to be a bunch of hosting specific tweaks. I appreciate the help or redirection to applicable solutions.

HI,

  1. Are you using PhantomJS or SnapPDF?

  2. Maybe you needed to run php artisan optimize after changing the .env file?

  3. I don’t believe Integromat supports v5 yet, Zapier is supported though.

https://zapier.com/developer/public-invite/95884/5e4368b9efb9d377dc0a0b0465b7c1a7

Hillel,

Thanks for the reply.

I was using PhantomJS I believe. Don’t recall seeing anything about SnapPDF. I also did run the unix command but that didn’t seem to do anything.

I actually ended up deleting that application and installing the latest v.4. I got that up and working, along with the Integromat and SMTP connections. I think I’ll just wait for later for v.5. I was wanting to evaluate I.N. as I had just recently found it.

For whatever it’s worth, I’ve been using Toggl as my time tracker. After integrating using Integromat, at first trial, it doesn’t look all the information maps 1:1. There doesn’t look like there’s an ability to log all the individual time entries in Toggl to I.N. unless I’m missing something. That may be on Integromat’s end or perhaps in v.4, those individual entries on a given project may just not be available.

Thanks.

1 Like