$clientDetails: addressing specific contact, custom field label shows


I’m currently running a self-hosted v2.8.1 of InvoiceNinja for testing before implementing it as our new invoicing software. It’s a convincing app and I’m thrilled by the reactivity both here in the forum and by the developer to integrate and release new features very timely. I can’t imagine how much of work this is … but thumbs up

I am stumbling over some behaviour of $clientDetails frequently used in the invoice templates:
#1: I added several contact names to the client as for different projects invoices need to be addressed to the respective project officer. Within $clientDetails it seems that it is always the first contact I added under that client that is shown on the bill. Is there a variable to address a specific contact or is it default to only show the first contact in line. I wanted to avoid a workaround which says “create a new client for each contact person”

#2: I added a custom field in the Clients tab under Invoice Settings. I labelled the field Department (a field I would guess should be a standard option under clients and not a custom field). Now when $clientDetails is invoked it shows the label Department followed by the text I put in that field for the respective client. Is there a way to not show the label in $clientDetails?

Many thanks in advance for any hints!

Thanks for the kind words!

#1 In order to ensure all recipient see the exact same invoice we currently always show the first contact. We’re considering changing this in a future release.

#2 You can remove the field from the invoice on /settings/invoice_design#invoice_fields

Hi Hillel,

thanks for your fats reply. Highly appreciated!

Response to #1: well noted

as for #2: I want to show the field content on the invoice so I do not want to remove it from /settings/invoice_design#invoice_fields. I only do not want the field label to appear on the nvoice
Example (currently showing)
Organization XYZ
Department: Département de Recherche where “Department:” is the label of the custom field
should show
Organization XYZ
Département de Recherche

and a short #3: how can I address the footer in styles in the invoice design. I tried
“footer” {
"fontSize: 6
but without luck. Any hint here

Many thanks

#2 You may be able to accomplish it by customizing the invoice design.


#3 You should be able to add “fontSize”: 20 on the ‘Footer’ tab.