Client shows - No data available in table after migration

hello All,

I migrated white label 4.5.11 to 4.5.23.
4.5.23 is on different server brand new install and I imported all the data from 4.5.11 into new database and forced the update with /update.

When I go into client specific page ( clinets/2) i see “No data available in table” but if I run View statement it shows all the data, same is for all the invoices. I checked other clients and its the same issue.

All other functions work and I can see that all invoice and payment data is intact.

I appreciate any feedback so I can fix the issue.


Did you use mysqldump to transfer the data?

I used phpMyAdmin, export with default options

I’m not familiar with it, we recommend using mysqldump

Do you see data in the activities table?

yep, table is full with data with correct client ID.

I have successfully migrated data before using phpmyadmin it just user interface to mysql.

Any other ideas where to look, assuming that data as migrated correctly. any specific files?

thanks for the help./

Sorry, not sure what else to suggest

tried mysqldump and unfortunately got the same results.

Just cannot figure out what’s different from 4.5.11 to 4.5.23 to cause that isssue

Hi Hillel,
I tried the following to narrow down the problem and make sure its not some sort of migration data problem.

I did brand new install of 4.4.11 and just duplicated database from working version and configured connection to it.

All is done on the same server. So database duplication was done right on the server.

When I go into new install, i am getting similar issue of data not showing, this time even invoices are not showing.

I tried the following:
I rebooted server
cleared all the cache ?clear_cache=true
new browser session

same issue.

I am trying to figure out if I am missing anything in environmental setup or some value in database.

Anything you can think off.


Sorry, I’m not sure what would cause it

Thanks for sticking with me.

I tried the following. Brand new install of 4.5.23, created client and invoices. and nothing is showing up under activity, same message as before.

If I go into other tabs under client like Tasks, Invoices, Payments they all have records listed but Activity shows “No data available in table”

I checked all the logs to see if any error messages, did not find any.

Just a fact that Activity is blank on a brand new install without data migration, I think its a bug.

I am totally stumped

Sorry I am back with more information, looks like it’s a bug in SQL query.

I had debug = true on 4.5.11 and 4.5.23


Ran queries from both on DB, set from 4.5.11 give results but set from 4.5.23 does not

looks like main difference is in this
4.5.11 contacts.client_id =
4.5.23 = activities.contact_id

I hope my research makes sense, thanks