Client and date selectors don't work in Invoice/quote creation

I installed yesterday Invoice Ninja 3.7.2, but client and date selectors don’t work in Invoice/quote creation. Fields don’t populate and the live preview is blank. There are clients created.

Thanks for your help.

  • Are there any errors in the browser console?
  • Which browser are you using/have you tried a different browser?
  • I’m not sure it’s likely help but please check if v3.8 helps.

Hello Hilled.
The browsers console don’t show errors.
I used Chrome, Chromium and Firefox, even in a different desktop, and the same situation
I installed Invoice Ninja via Softaculous, and they don’t have 3.8 yet.

Thanks for your help.

Did the live preview work initially?

Maybe try purging the data on /settings/account_management

Thanks Hillel.
At first, just installed, everything works well, but ten minutes later appears the problem. I did purged data yesterday but nothing change.

Are you using a custom design?

No Hillel. I have not configured or customized anything because of this problem. I just added a client for testing, nothing more.

I’d suggest starting with a blank database to try to figure out which setting change caused the live preview to stop working.

I’d also suggest checking storage/logs/laravel-error.log for any errors

Hillel, like I said at first, it’s not just live preview, but client selector and date selectors that don’t work, don’t populate data. So, you suggest the same?


Hillel, this is shown in storage/logs/laravel-error.log:

[2017-10-19 01:35:50] production.ERROR: Swift_RfcComplianceException [0] : /home/conexnub/public_html/ninja/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Mime/Headers/MailboxHeader.php [Line 345] => Address in mailbox given [] does not comply with RFC 2822, 3.6.2. {“context”:“PHP”,“user_id”:1,“account_id”:1,“user_name”:“System Administrator”,“method”:“POST”,“url”:“",“previous”:“”,“user_agent”:"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.62 Safari/537.36”,“ip”:“”,“count”:1,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”} []

It looks like a problem with email settings, you can check them in the .env file.

It isn’t related to the problem you’re seeing in the UI.

Ok Hillel. So you suggest then, start with a blank database?


Hillel, I completely delete the installation via Softaculous, and I just did a brand new Invoice Ninja 3.7.2 installation, but… the same thing! date and quote fields don’t populate, etc…

Sorry, not sure what to tell you. Do you recall what changed to cause it stop working?

Also, can you double check for any messages in the browser console.

Hille, now it is a brand new installation, with no data at all. In console, under Invoice Date field, appears “create:1 Failed to start loading”

Maybe it’s related to SSL, I found the same error referenced here:

ok Hillel. So, try to disable ssl? How can I do that?