Can't log into Time Tracker app on Mac

I downloaded the Time Tracker app to my Mac. I clicked the link for self-hosted login and pasted in my exact url to my self-hosted InvoiceNinja install. Every time I try, I get this error message:

"Not Found

The requested URL was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

I am absolutely I am using the correct url. I log in there every day and even double-checked after I got the above error message. I have tried using the full url with https:// and without. With it I get the above error. Without it, I get a message to use a full url.

Anything in /storage/logs/laravel-error.log with a timestamp matching the login attempts?

Also, the URL for logging into the time tracker should be https://your-ninja.url/time_tracker, IIRC. (Edit: Nevermind, that’s for accessing it from a web browser.)

There is nothing in that error log except two entries from early December, 2019.

I tried the url you gave me (of course with my domain inserted) and still got the same 404 error message.

With it being a 404, there might also be something in the webserver error logs.

This is the latest error in the server log. It occurred about the time of the last effort to log in.

“[2020-01-15 12:28:12]: uid: (1061/qpmedia) gid: (1064/qpmedia) cmd: redirect.cgi”

I even tried the url, which is the domain that I see when I open time tracker from within InvoiceNinja. When I use that url in the downloaded time tracker app for Mac, I get this error message:

“Sorry, the page you are looking for could not be found.”

I get that error message even though I had that very page open when I opened the time tracker via a project from within the self-hosted InvoiceNinja app.

I just downloaded the Windows version and tried it on a Windows 10 desktop computer. I used the domain and got the same result that I got with the Mac version.

“Sorry, the page you are looking for could not be found.”

The difference is that in the Mac version, I could use the “Clear app data” in the file menu to clear the app and retry. In the Windows version, I can’t find any menu to do anything with the app.

On the Windows version, you can go into C:\Users&lt;username>\AppData\Roaming\invoice-ninja-nativefier<somestring>\Local Storage. Then simply delete https_yoururl.localstorage and https_yoururl.localstorage-journal.

And yeah, I was mistaken about putting /time_tracker on the end of the URL.

Titanfail, thanks for your input.

I can’t get into the time_tracker app using any of the following urls.

Can anyone tell me what the issue is? I can log into with no problems at all. I can use the time tracker from there. But I cannot log into the time tracker app on either Windows or Mac.

I want to be able to track time without opening InvoiceNinja on both computers.

Not sure what could be going on, as I’m unable to recreate the issue. Is your server behind any kind of proxy?

For now, you might consider just opening another browser tab and logging in with the /time_tracker address. The time tracker app is essentially a standalone browser that only connects to your web server anyway.

My server is not behind a proxy. InvoiceNinja is installed in a subdomain of my public business website.

Time Tracker will open in a normal browser window, just not in the window the downloadable app provides. And that applies to Windows as well as Mac. Same issues on both.

I can live with opening a browser window with the Time Tracker URL. The whole reason for this effort has been to allow another person in the office to use the time tracker when she is working on projects so that her time can be tracked. She has no need for any other InvoiceNinja feature.

Will InvoiceNinja allow two people to track time on one installation at the same time. Say, me, using it from the main installation, and my assistant using just the time tracker on a different computer. Will InvoiceNinja work that way?


If you login from your-ninja.url/time_tracker (instead of the normal address), it will only bring up the time tracker, and it won’t show any of the other features. The desktop app is simply a browser that only goes to that one address and has no navigation features.

You could mimic that behavior by setting a shortcut to open the browser window in app mode. For Chrome, you would add –app=https://yourninja.url/time_tracker when providing the path to the binary. So in Windows, it would be something like "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --app=https://your-ninja.url/time_tracker, whereas in OSX it would be /Applications/Google\\ Chrome --app=https://your-ninja.url/time_tracker

Place that shortcut on the desktop, name it “Time Tracker” and you should be good to go. And you can still open and use the browser normally as well. The shortcut does nothing but open a kiosk window to that URL (and should remember the window size of you change it, also).

As for two people using it at the same time, if she has her own login I don’t see any reason why it wouldn’t work. But I’m just an end-user so not 100% sure.

I set my assistant up with limited admin rights. I set a bookmark in Chrome on her computer that opens the time tracker. It appeared that all was right until I discovered that if the same project was open on my Mac and her PC at the same time, the time tracker didn’t seem to be tracking separately, then recording the separate times.

I then broke the project into two. One for her and one for me. I’m hoping that will allow both of us to track our times. In this case, it won’t matter if the two users’ times are recorded under different projects as long as the total time is kept.

I was surprised to see that the user manual does not discuss projects or the time tracker. That leaves users to figure it out on our own.