Can't get past initial setup - PDF Test Fails

Hi all,

I have Invoice Ninja installed on Ubuntu Server 20.04 in a self-hosted environment. I have it up and running partially in that I can access the initial setup page. I am running this behind HAProxy which does my SSL termination with Let’s Encrypt. I had to edit the nginx config accordingly to listen on port 80 and remove the SSL stuff. I have added the IP of my HAProxy instance to the “TRUSTED_PROXIES” in the .env file.

Interestingly, the setup page differs from the one in the demo install video. Has it been updated since that video was made? I don’t see any setup regarding database, email, or users so far. The only setup I see so far is URL, Force HTTPS, and Test PDF.

I can’t get past this setup as the PDF test isn’t completed. I am not sure why. I have read the troubleshooting sections of the docs and switched the provider over to snappdf. But it still isn’t working. I have run the php7.4 artisan optimize command after making any changes to the .env file, and rebooted the server for good measure.

Any ideas what the problem might be? Is there anything else I need to do to make snappdf work other than specifying it as the provider in the .env file?




PhantomJS is easier to use but SnapPDF is faster.

There’s info on setting it up here:


Yes, I have already looked at the GitHub page for snappdf. It seems like it’s a package that you would install into a development project though.

I have tried the Phantom option too and that doesn’t work either. The test fails.

How can I troubleshoot this further? Are there any logs I could be checking?



Same problem here.

The Setup Page doesn´t show database fields and won´t advance as Test Pdf button output is “Oops, looks like something isn’t correct!”

Console log error: /setup/check_pdf 500 (Internal Server Error)

See my journey over the past few days to get this working. I went through all of this and now appear to be 100% functional as of a few minutes ago when I fixed a typo in my email address.


i have a fix for this in v5.3.26

I was following that thread too. Trying things out, but nothing worked out.

What did work at last was changing permissions to 777. Then database configurations showed up. Configured database, email, user data and everything correct. Final step and it went back to the first setup page with the “Opps…” error. I will try the 5.3.27 version now

Tried the v5.3.27 and worked perfectly!

1 Like


I managed to solve this by installing a long list of dependencies for snappdf. After doing that the PDF test passed.

sudo apt install ca-certificates fonts-liberation libappindicator3-1 libasound2 libatk-bridge2.0-0 libatk1.0-0 libc6 libcairo2 libcups2 libdbus-1-3 libexpat1 libfontconfig1 libgbm1 libgcc1 libglib2.0-0 libgtk-3-0 libnspr4 libnss3 libpango-1.0-0 libpangocairo-1.0-0 libstdc++6 libx11-6 libx11-xcb1 libxcb1 libxcomposite1 libxcursor1 libxdamage1 libxext6 libxfixes3 libxi6 libxrandr2 libxrender1 libxss1 libxtst6 lsb-release wget xdg-utils libgbm-dev libxshmfence-dev

Had no problems with the database test.

Email SMTP I have a problem with though. Does Invoice Ninja support O365 Relay/Connector SMTP? The Relay/Connector type is what I have to use because my user login is prtected by 2FA. The is no username or password when using Relay/Connector. The connector with O365 only accepts email requests from my public IP instead. From what I could tell, unless a user and password were entered, it wouldn’t even attempt to test the email. To get through the setup, I had to select “Log” for email. I’m hoping I can change the settings later.