Can't connect to local server if server is not connected to the internet

Hi everyone. I’ve been using invoiceninja a while and have a problem with it. I updated the server to 3.8.1 and everything worked fine. I later discovered that I still had the internet connected to this server and I changed it back to offline, so that I can only reach it on my LAN. But now I cannot login to the server, it waits after I put in my credentials and times out. And if I reconnect it to the internet everything works. Is there any way to change this? It worked when I was using 3.6. I don’t need it connected to the internet and only want to use it on my local LAN

It sounds like an internal DNS resolution issue.

Depending on your operating system you will need to create a record in the /etc/hosts files with your ip address and the internal name you are using for your installation.

I’m able to go to the server, and fill in my password etc. But then it times out while trying to login.

We can only provide support for the current version of the app but I agree, it seems like a configuration issue.