Can't add Wells Fargo Bank Account for Expense Import 4.5.17

Running Self-Hosted 4.5.17. When I try to add a bank account (Wells Fargo) via Settings > Credit Cards & Banks > Add Bank Account, I get the error “Failed to retrieve account details, please check your credentials.”

I tried doing the same on my trial account, and it says the same “Failed to retrieve account details, please check your credentials”.

Also tried Ofxget successfully.

I’m 100% sure the credentials are correct.

Any ideas how to fix? Seems others are having the same issue.

Version: Self-Hosted 4.5.17

Laravel Log:
production.ERROR: ErrorException [0] : /var/www/html/ninja/Libraries/OFX.php [Line 45] => Undefined Offset: 1

Was it working for you with a prior release?

No, It wasn’t working for me with a prior release

It may help to check with the bank to see if Quicken Online is supported, we use OFX but it uses their protocol.

There is an opensource app called OFXGet you can use to test your credentials but it’s built using old tech and I can’t guarantee it’s security.

Unfortunately I’ve already tried OfxGet successfully, and quickbooks online is supported by the bank

Okay, so I found some very useful details on at this tread:

  1. The first thing is TlS 1.2 is apparently now required by wells fargo for Oxget. Not sure if this has to be implemented into software or if it’s something I’ll have to do since i’m self hosted

  2. Two factor auth is now required. You have to enter your credentials and confirm via phone or text at this link ( and then you have 10 minutes to enter your data.

  3. They also change a $3/mo fee for OFX. Time for a new bank

I also am now getting an HTTP response code of 400 for URL: