Cannot Connect to Stripe Connect

I just migrated to V5 and I cannot connect to Stripe Connect. Endless loop. Click to configure gateway and it takes me to a page that says I’m already connected. But I’m not. None of my clients are able to pay their invoices. I deleted that gateway to start all over and I can’t even get it to stick as a gateway. Same thing, says I’m already connected.


@david any ideas to debug this?

@hillel We resolved this one over support email.

Thanks everyone for helping me on this one. For everyone else that might see this, here is what happened and how it got fixed.

PROBLEM: About a year a go, I started the migration over to V5 (Hosted). I ran into some issues and instead of trying to resolve those I reverted back to V4. Since then I had changed my primary email address, which is what caused this issue. When migrating back to V5 this time, it created another instance because of the different email address. When I kept trying to connect to Stripe, it said I was already connected, but I really wasn’t. When/If you revert back to V4, that instance of V5 is still in the system.

SOLUTION: Had to delete the old V5 migration, once that was done, Strip Connect worked as expected with the new migration to V5.