Can I install Self-host without GMP?

Im trying to install “Release v5.0.35-release” Self-host on my domain for personal use.

The domain and server-integration are provided by I can not start the installation because gmp is not supported by They do not want to support this “because of security”.

Is this required to be able to run the Self-host version on my own server, or can I bypass this requirement in any way? There is no error message or explanation of what I can do next.

Thank you very much for your time and help

Hi Marty,

You could try commenting out line 31 of app\utils\SystemHealth.php and see if the application works. This would remove the gmp requirement from setup.

1 Like

Hey! Thank you for your suggestion David. Removing gmp from SystemHealth.php got me past the error messages page. I also see that latest v5.0.38 release has this commenting out by default. Unfortunately, It will not move on after this either. Please look at the screenshot.

This may not be a GMP issue anymore. I can fill in the form, but the database test does not work and the database is not created. I get no error messages, other than that I get a 500 error on the /public page.

I also get the URL wrong. Could it be that there are some files missing in my upload? I have tried to upload everything 4 times now, all files at once and also one and one folder to be sure that everything is included, but same error. As you see on the screenshot, the page is not formatted either, is it actually formatted with css?

PS! When I tried to install version 4.5 it worked to create database without any problem, same settings.

If anyone has more tips I really appreciate it! I try further and will test another host.

This is weird if your server configuration is correct.

May I know, do you host on shared hosting or have your own server?

For the 500 error, I suggest checking the logs. You can find them in:



I use a shared host via the domain site “”. They are among the cheapest, so I don’t expect everything to work with them. The idea was that it was easier to use Ninja via that hosting than to set up my own server, but it might seem that I have to do it instead.

Unfortunately, I do not have the log as I have once again tried to delete the files and try to upload again.But I think this is a shared host issue.

Thank you so much for the suggestions and help!

I’m sorry, but without logs, it’s really hard to debug this.

I am sure they will provide access to logs. Do you have a File Manager in the control panel?

it looks like you are including /public in the domain name, i believe this will cause resolution issues. You will need to rewrite the URL to remote the trailing /public

we have a built in .htaccess which should do this, i’m unsure whether your hosting provider is actually reading this in?

I tried commenting out gmp
Still setup stops at

The only errors are from yesterday due to a duplicate db user, not related to current issue.


Seems it is not possible to install V5 with unless anyone can suggest something else to try.

What message do you get when you click Test Connection for the DB?

Oops, looks like something isn’t correct!


Seems I get that on all steps and submit produces 500 | Server Error

Honestly I think this is a problem with, they limit pretty much everything on their platform.

perhaps… i would double check that you have created a database called db-ninja-01 and added the user ninja to that database.

I suppose any db credentials will do, the host forces the prefix domain_ to all db’s.

Hi! Sorry I did not respond earlier. This project was postponed for a while, but now it became relevant to me again :slight_smile:

I have been in dialogue with regarding the latest information under “Shared Hosting” in the manual. confirms that “proc_open” is closed on their platform. The same is “shell_exec”, “passthru” and “exec” (see picture). It is therefore not possible to install the latest InvoiceNinja on their shared hosting service.

Thank you for all the tips and suggestions! Now I need to install it locally instead.