Bug: Company default values not filled in when converting a quotation to invoice

When converting a quotation to an invoice, in the past it would take the “invoice conditions” value from the company defaults settings, however this is no longer happening.

When creating an invoice from scratch the value is properly being pre-filled.

Steps to reproduce:

  1. Go to settings → Company → Default values and make sure the “invoice conditions” are filled in. (Not sure if it matters but we have default values for both the header and footer for invoices and quotations)
  2. Create an invoice and check that the value is properly being propagated (this is ok)
  3. Create an quotation for a client.
  4. Mark it as sent
  5. In the quotation overview click the 3 dots and select “convert to invoice”
  6. Go to the created invoice and click on edit. The default value is now NOT being filled in. Instead it still contains the conditions of the quotation and you will have to change it manually.


@david can you please advise?

1 Like

Terms from the quote are carried over to the invoice, I believe this is expected functionality.

I believe in v4 if the account has invoice terms they’re used instead.

No it is not. We have different terms for quotations as for invoices. As soon as the quotation is converted to an invoice it should state the invoice terms. This used to work up until a few weeks ago (don’t know exactly when).


We changed this recently so that quote terms move over to the invoice.

Should we add a flag to control the behaviour of this?

1 Like

That works for me, I think by default we should follow the v4 behavior of using the invoice terms.

1 Like

@bramdriesen I believe the functionality will be as you expect by default in the next release.

1 Like

Awesome! Thanks :slight_smile: I will test and let you know if it works as expected :wink:

When will this be deployed to the hosted version? I see it’s still on version v5.3.88-C84 and not the 5.3.89 containing the fix.


This will be available this coming Sunday, we had to delay last weeks release.

1 Like

I just tested this and it is indeed fixed! Many thanks.

1 Like