Blank System Logs?

Hi everyone, I’m actually trying to troubleshoot an email issue, but can’t seem to see anything in System Logs. I’ve tried multiple browsers with the same result: blank frames. Can’t seem to find anything in the forum that got answered.

Any thoughts?


Are there any errors in the browser console when you load the app with ?build=profile at the end of the URL?

Looks like I get:

NoSuchMethodError: method not found: 'gii' (J.aZ(...).gii is not a function)       js_primitives..dart:47
Another exception was thrown: Instance of 'minified:lW<void>'                         js_primitives..dart:47

Is that with loading the app with ?build=profile at the end of the URL?

The profile flag should show the error un-minified which is more helpful

That’s what I get when I load it with: https://URL.DOMAIN/public/index.php?build=profile#/

I’m not sure, that looks correct.

That said from the URL it looks like mod_rewrite may not be enabled (index.php shouldn’t be in the URL) and the webroot should ideally be mapped to the public folder (/public shouldn’t be in the URL).

To debug the issue it may help to access the system_logs table in the database directly to check for more info.

Hmm, I seem to be getting this error:

Address in mailbox given [] does not comply with RFC 2822, 3.6.2.

Here’s my redacted Mail info from my .env:


Once I make changes to my .env, there isn’t anything I need to do to reload them, do i?

After changing the .env file you may need to run php artisan optimize

hmm, I’m on shared hosting, so I may have to contact my hosting provider.

Also, I did check my .htaccess file and this is at the top:

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteRule "^.env" - [F,L]
#  RewriteRule "^storage" - [F,L]
  RewriteRule ^(.well-known)($|/) - [L]
  RewriteRule ^(.*)$ public/$1 [L]

On shared hosting you may be able to load /update?secret=

1 Like