Blank gray screen after update to 5.3.56

Hello everyone!
I wanted to upgrade InvoiceNinja to the latest version and found that some kind of write permissions problem hindered it from updating. I fixed that, got the system updating and after the update, all I see is gray screen upon going to https://xxx.mydomain.xx
What i’ve tried:
sudo chown www-data:www-data /var/www/html/invoiceninja/ -R
sudo chmod 755 /var/www/html/invoiceninja/storage/ -R
Countless other chmods e.g 777 etc
laravel.log is empty
sudo php artisan config:cache
sudo php artisan config:clear
sudo php artisan migrate:fresh --seed gives me the setup screen, after setup it’s blank screen all over again.
apache2 error logs contain nothing useful
php settings checked, env file checked, apache2 configs checked
Any ideas?

Hi,

It may help to add ?clear_local=true to the end of the URL and then log back in

Hello, thanks for the quick reply.
however the offered solution did not help

Are you able to login using a different browser?

I’ve tried Chrome, Firefox, Edge.
But to no avail.

Do you see the login screen?

Are you able to login with the mobile and/or desktop app?


This is what I see.
This is a collaboration effort project by my team, none of us can login anymore.

Are there any errors in the browser console?

Are you able to login with the mobile and/or desktop app?

No errors whatsoever on the browser.
The desktop app does work like intended though.
But i’d like to have access through the browser too.
Follow up: we can access and login through mobile phones, but not on any of our computers. Seems to be a cache problem?

Have you checked the browser console?

Hello again
Browser console:
main.foss.dart.js?v=5.3.56:158 Refused to load the script ‘https://unpkg.com/canvaskit-wasm@0.31.0/bin/canvaskit.js’ because it violates the following Content Security Policy directive: "script-src
Refused to load manifest from ‘https://xxx.mydomain.xx/manifest.json?v=5.3.56’ because it violates the following Content Security Policy directive: “default-src ‘none’”. Note that ‘manifest-src’ was not explicitly set, so ‘default-src’ is used as a fallback.

I’m not sure, @david do you have any thoughts?

It may help to add ?build=html to the URL

After looking into the error, it seems that it’s not an InvoiceNinja problem, rather the CSP setting is blocking my website.
Thanks for your time, good night

1 Like