AWS and Centos 7.8 instance

Hey Hillel,

I am running an AWS instance with multiple accounts under whm. I have IN installed under a subfolder of one website account in WHM. Is this where I need to configure or create the cron or should it be created on the AWS instance itself? Still having issues getting the cron installed/started.

Hi,

@david do you have any suggestions?

whm/cPanel can manage the crons for you.

Do I create the cron job in whm or in cpanel for the specific account? In WHM, this is the only thing I see related to crons… " Configure cPanel Cron Jobs"

In CPanel, this is what I have:

Minute Hour Day Month Weekday Command Actions
13 7 * * * cd /home/xxxxxxxxxx/public_html/acct1 && /opt/cpanel/ea-php74/root/usr/bin/php -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1 Edit Delete
0 0 * * * cd /home/xxxxxxxxxx/public_html/acct1 && /opt/cpanel/ea-php74/root/usr/bin/php -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1 Edit Delete
* * * * * cd /home/xxxxxxxxxx/public_html/acct1 && /opt/cpanel/ea-php74/root/usr/bin/php -d register_argc_argv=On artisan schedule:run >> /dev/null 2>&1

Invoice Ninja still says crons not enabled

@david @hillel

You only need one job that runs every minute ie. * * * * *

I tried each option but still had the Red triangle. I will remove all of them except for the *****

@david @hillel

I tried each option but still had the Red triangle. I will remove all of them except for the *****

@david @hillel

Hey Guys… Any Ideas?

@bggunnz

Are your recurring invoices / reminders / autobill tasks working?

I haven’t even got that far to set that up as none of my clients do require that.

If you click the red triangle, is it still saying “crons aren’t running”, or is it complaining about something else? If it’s still cron, try removing the " >> /dev/null 2>&1" part for a while. You should then receive the output of the cron jobs by mail. (Receiving a mail from cron every minute will turn into a nuisance quickly, so be prepared to put it back in after a few minutes.)

Red Triangle says “The crons need to be enabled”

Removed >> /dev/null 2>&1 temporarily to see what happens

@xoo

So far, no emails received
@xoo

Without the output redirection cron should generate one email every time the job is run, so every minute in your case. Either emails are delivered to an unknown place or cron ain’t running.

How can I force the cron to start or run and how can I check the status?