Automatically Generated Invoice Numbers Not Working


With v4 the invoice numbers are automatically generated when creating new invoices. It is not the case when using v5.

Is there a setting that needs to be enabled for it to start auto generating the invoice numbers?


Maybe it’s set to set the number on send? It can be configured on Settings > Generated Numbers.

1 Like

… which is actually a very good setting, if you like to draft invoices (like I do) some time in advance, and later on decide you don’t need that drafted invoice for whatever reason and instead of sending want to delete it. Tax folks (at least in Germany) throw a huge fit if the invoice number space ain’t continuous.


You are right, it generates the number after it is saved. I honestly never noticed this before in v4.

Thank you as usual.