Auto billing does not work

Hi there.

I am having an issue regarding the auto-billing feature for recurring invoices. I am using Payfast as a payment gateway.

I am testing this feature by having a recurring invoice with a frequency of daily and paying a small amount to test.

The recurring invoice is currently active and sends a normal invoice each day to the “client.” I still notice that a manual payment needs to be made.

Is there any way for the payment to be automatically made?

Kind regards.


Does the client have a card on file and is auto-bill enabled for the recurring invoice?

I did enable auto-billing for the recurring invoices. I will attach some of the screenshots.

I also noticed that you could not deselect the “pay with a new card” option from the client’s end when paying the invoice

From the screenshots it looks like the client doesn’t have a card on file.

Is the capture card option enabled in the payment gateway settings?

Yes, it is.

@david do you have any thoughts?

If you navigate to the Payment Methods section in the client portal do you see a payment method on file there?

It does not look like there is anything there. I also noticed that when I wanted to add a payment method, it gave me the following message from Payfast. I attached screenshots.

Is there any information in payfast about this error? I’ve tested against their sandbox environment and cannot reproduce this, however I don’t have production credentials so there may be something we are missing here.

OK, so I went into the dashboard of Payfast under the settings > recurring billing

I then enabled tokenization.

It seems that I can now create a payment method inside the client dashboard. I am going to run another recurring payment to test it again. Here is a screenshot. I hope this works.

For what it’s worth, I’ve never been able to get auto-bill to a credit card on file to work either. I use WePay… I gave up trying to fix it. The invoices are created and sent each month and I have to go in and open each invoice manually, open the customer portal, click all the buttons and links to pay the invoice manually using the customer’s card on file. It’s really maddening but I don’t have time to work through this issue, so I have just dealt with it each month.

I doubt it’s a setting in WePay since it doesn’t even attempt to charge the customer’s card, ever. It just creates the invoice. Yes I DO have the option set to auto-bill on the recurring profile by the way and the customer DOES have a card on file since I charge to it manually each month. This is for each customer that I use recurring billing for, not just one.

@david do you have any suggestions to debug this?


If you want the recurring invoice to billing immediately you’ll want to change the auto bill setting from On Due Date to On Send Date

This would explain why your autobilling appears to not be working.

Thanks, I changed it and we will see if it works now on the first of next month.

Thing is though the Send Date and Due Date are the same on these invoices. So… Not sure why this setting would work any different but I guess if it fixes my issue, I don’t care lol


The recurring invoice may generate before the “due_date” autobill process runs. Changing to On Send Date will resolve the issue. Let us know if you have any troubles.

I also changed mine. Let’s see if it works.

Do you need to set the standard invoices to auto bill as well to resolve this issue?


Two options here:

  1. Recurring Invoices - autobills invoices generated from recurring invoices.

  2. Standard Invoices - invoices that are created from the Invoices tab.

Your current config will attempt to autobill as soon as the recurring invoice generates its invoice.

This did fix my issue FYI. Wanted to update this in case anyone else has this issue. Thanks for the assist.

1 Like