We have some Recurring Invoices that are set to Auto-Bill. We have that set to “Always” in the two places where that’s an option.

When the Send Date hits, the invoice gets emailed, but there is no Auto Payment. DO I have something set incorrectly?

Please advise.

I’d suggest checking that the card on file is valid by trying to manually bill the invoice.

Sorry. How do we manually bill the invoice with the card on file? The card is in the system, right?

Click ‘View in portal’ on the edit invoice page and then ‘Pay now’

The payment page comes up with pre-populated info on everything but the credit card. So, how is the card “on file”?

If you have a card on file you’d see a ‘Use card on file’ option when clicking ‘Pay Now’

Which payment gateway are you using?

We’re using First Data for the gateway.

That would explain it, we only support auto-billing with Stripe, WePay, GoCardless and Braintree.

This supported gateways are listed in the app, did you not see it?

I could have sworn that I tested the auto-billing way back when I was evaluating your platform. I guess I took “Auto-Bill” to mean “Auto-Pay”.

Could we have multiple gateways, so that the Auto-Pays go thru Stripe and everything else goes through the First Data gateway?

OK. We switched to Stripe and a client paid their first invoice today (generated from a recurring profile). How can I see whether the platform stored the token so it can be auto-paid next month?

If you have a token you should see a ‘View in Stripe’ button on the client overview page.

Perfect. It was there. Thanks.