Auto-Bill Generates Invoices but doesn't charge Card on File

Before my upgrade from v4 to v5, my recurring invoices would always generate on the 1st and then automatically charge the clients credit card on file Since the migration to v5 this has not been happening. The recurring invoices do generate, but the clients card on file is not being charged. I have been having to manually go into the clients portal each month and pay the invoices using the card on file. Because I only have a couple clients set-up this way, it wasn’t a huge issue for me but it would be nice to have it back to auto-charging the cards on file so that I don’t have to manually do it or in case I am not able to get to the portal on the 1st. Is there something I am missing here?


Is auto-bill set to enabled for the recurring invoices?

Yes, it’s set to enabled. The invoices themselves generate on the 1st of each month but just stay there as “outstanding” until I view the invoice as the client as pay it with the card on file.

Do you see a failed auto-bill attempt in the client’s system logs?

@david any thoughts to debug this?

There is entries saying “performing autobilling” and then I went back to December and I found the following one as well:

production.ERROR: Maximum execution time of 30 seconds exceeded {“exception”:"[object] (Symfony\Component\ErrorHandler\Error\FatalError(code: 0): Maximum execution time of 30 seconds exceeded at /home/cpanelusername/URL/vendor/laravel/framework/src/Illuminate/Database/Eloquent/Model.php:2155)

Otherwise the rest just say: production.INFO: Performing Autobilling 2022-12-01 12:30:03

That looks like it’s from the app logs in storage/logs, there may be more info in the system logs in the app.

Yes sorry those are from the app logs. I checked the system logs and the only entries there are from when I manually process the payments myself after the invoices have generated. Is there anything in particular from those that would help troubleshoot the issue? There are items under “response” and “data” like the amount, payment method, status, client email, etc.

Ok, I think we’ll need to wait for @david

1 Like

It sounds like a failure is happening before the autobill here, are you sure your PDFs are generating correctly, even when they update?

PDF’s appear to be generating correctly as the client is getting their e-mail and the invoice appears. Looking at the activity section, it shows the system updating the invoice and then e-mailing to the client.


One thing to check, open an invoice that did not “auto bill” and go to the settings tab and see if the auto bill toggle is on or off.

Doing that brings me into the “Client Settings” so I clicked on “payment settings” and I checked, some of them were blank and others were “enabled by default”. I have changed them all to “enabled”, set the bill on to “send date” and the payment type to “visa card/mastercard, etc”. I’ll see how the auto-billings go for the February 1st billings and hopefully they’ll be back to normal now.

Just to clarify, this is where I meant,

In the generated invoice itself, double check that the system is indeed marking them to autobill, as you correctly noted, if the recurring invoice is not setting them to auto bill then they won’t auto bill.

Ah, thanks for the clarification! I’m still not 100% familiar with the UI changes for v5 :slight_smile:
I checked that area for one of the recurring invoices I manually processed payment for after it was generated, and “auto bill enabled” was not selected.

ok, so, it sounds like you have fixed this already in the step before, setting auto bill on the recurring invoice will propagate the settings down to the invoice when it is generated.