Authorize.net Problem

Since upgrading to V5, attempting to process credit card payments via our authorize.net gateway generates the error “customer Information manager is not enabled". This feature has never been enabled in or auth.net account and worked fine in V4. I assume this is related to the “Capture Card” value in the gateway settings, which is set to “Disabled by default”. “Disabled” also does not work.

Hi,

@david do you have any thoughts?

@dwulfman

In V4 I believe we only supported one time payments with auth.net

In V5 we support token billing which requires that we create a customer first, followed by a token.

You’d just need to enable with CIM in auth.net and then everything should work.

We ONLY process one-time payments and don’t need the recurring feature provided by CIM and have not activated that optional service in our account. How can we get this to work for one-time payments?

@david, any suggestions?

One time payments can still work fine. You can disable capturing the clients payment credit card in the system.

I believe in v5 we still capture the client details (name / address etc) and pass that through to authorize.net, so the CIM would still need to be left on.

I enabled CIM in our authorize.net account and ran a test invoice payment using two different cards known to be valid. Now we have a different error:

Error: There was an error processing your payment [33]. Please try again later.
Message:
Card Code is required.

The v-codes were entered.

Also – ACH does not appear to be an available payment option with Authorize.net. Is that correct?

1 Like

ACH would be fantastic addition to Auth.net in v5

1 Like

I can confirm Authorize.net eCheck is not an option right now.
Really wish it was! I am trying to use GoCardless, but I cannot make that work either. But if Auth.NET was working with eCheck that would be a better solution for us.