ApplePay Stripe doesn't work

When trying to pay using Apple Pay the payment doesn’t go through and stops at “Payment Not Completed”

This is self hosted on PHP-FPM 7.3 and NGiNX.

In the access logs I see the following
XX.XX.XX.XX - - [26/Jun/2020:21:25:16 -0400] “GET /payment/lipcwXXXXXXXXXXth2pskebhwlsnjorm HTTP/1.1” 200 8056 “” “Mozilla/5.0 (iPhone; CPU iPhone OS 13_5 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.1 Mobile/15E148 Safari/604.1”

Do you see any error information in Stripe?

Thank you. I didn’t realize I was able to view the logs. That’s awesome. Yes there’s an error here it is.

Request POST body
“amount”: “1000”,
“currency”: “USD”,
“confirmation_method”: “manual”,
“confirm”: “true”,
“description”: “Invoice 20200626_0011”,
“payment_method”: “tok_XXXXXXXXXXXXXXXXXXXXXXXX”,
“customer”: “cus_XXXXXXXXXXXXXX”

Response body
“error”: {
“message”: “A token may not be passed in as a PaymentMethod. Instead, use payment_method_data with type=card and card[token]=tok_XXXXXXXXXXXXXXXXXXXXXXXX.”,
“param”: “payment_method”,
“type”: “invalid_request_error”

According to this issue this error can occur is a customer does not exist in Stripe, maybe it was manually deleted?

Not that I’m aware of. I haven’t done anything within stripe to cause anything to get deleted. I just tried to remove my previous payment method in InvoiceNinja and try Apple Pay again and it still didn’t work.

Sorry, I don’t have a solution for this.

I suggest trying again with a new client in Invoice Ninja to see it it help.

Just tried that. Still no luck :frowning:

Sorry, I’m out of suggestions…

We’re releasing the beta soon for v5, hopefully it will resolve the problem

Ok. Does the beta support bitpay api v2? I noticed that’s also doesn’t work as of right now either since bitpay deprecated their v1.

Not yet but it’s likely we’ll add it in the future