Android app setup issue with self-hosted v4.3.1

Hi there,

I just discovered InvoiceNinja and it’s awesome. I’m playing around at the moment to assess its capabilities and I love it. So far everything went pretty smoothly: web application installation (self-hosted), configuration and testing on computers. However now I’m having an issue with the configuration of the Android app (I haven’t tested with iPhone). I naturally downloaded InvoiceNinja app v 1.15.0 from Play Store on my Samsung S8 Plus. After setting up web app on the server, the URL and the API_SECRET on the mobile app as per the documentation, I hit the confirm button and got the error message “Something went wrong. Undefined error occured.”

Any help would be much appreciated.


The most common reasons we see failures:

  1. In correct URL: Test your URL YOUR_URL/api/v1/ping?api_secret=API_SECRET

Should return success

  1. Invalid / self signed SSL.

I am having the same issue. I install invoice ninja on my website, download the mobile app to login and it request that I enter the API_SECRET. I went through the document and i can find the " .env file".

Pleased I need the file name where the (.env file) so i can work on it. steps, name and location of the file to access (.env file) will be appreciated

So I have upgraded to 4.5.1 and have tested with the URL: https://YOUR_URL/api/v1/ping?api_secret=API_SECRET

and I get:
“error”: {
“message”: “Invalid token”

I have changed the API SECRET value but I still get the same result.

The SSL certificate is handled by “Let’s Encrypt”.

Any ideas?


Hey @mayol,

“First, you’ll need to add an additional field to your .env file which is located in the root directory of your self-hosted Invoice Ninja installation.”

Check in the root of the folder of your app and make sure you can see hidden files.


I am too having problems with the Android app with v4.5.4. I have added the API SECRET key to the env file and the API ping url returns “success” but the app won’t connect.

Looks like it can create a token, though.

I also have problems with Zapier. Never managed to fix it, I’ve given up after trying for many hours and creating one thread here.

I really cannot understand what the heck is going on. Every test so far seems to indicate it is working okay.

Same issue with me as well.

Downloaded app from Google Play. Setup everything, and I get a message 403: Invalid value for API_SECRET. When I run the ping test above, I get success. I have purchased white label, and the SSL is through LetsEncrypt.

Scratch that. I commented out API_SECRET and logged in with none. Then logged out, un-commented it, changed it, and it let me log back in.