500: Unable to generate the raw PDF?


I just received this error after updating to the latest version (v5.5.44-C102) and attempted to send a test invoice to myself.
Any idea what could be the cause of this @hillel ? :thinking:

Thanks in advance. :pray:


Which PDF generator are you using?

Hi Hillel and thanks for your reply.

We are using the default option of Phantomjs:
it has worked very well in the past so I am not sure why it is starting to troll me now… :thinking:

Kind regards

Thanks! It should help to change to hosted_ninja and then run php artisan optimize.

cc @david

Ok, thanks
I’ll will try later today and test it and get back with a status whether it worked or not for me.

Kind regards

v5.5.45 should address this, if not, use hosted_ninja :slight_smile:

What is that parameter different from the “self_hosted” parameter in the .env file @david?


hosted_ninja refers to the PDF driver,

options are snappdf, hosted_ninja or phantom

selfhost release to the environment people are using, which will always be selfhost for the community :slight_smile:

Oh you meant like that…
Now I get it. :smiley:
Thanks David!

I seem to be having the same issue after upgrading to v5.5.45. No PDF generation when using snappdf. Changing to PDF_GENERATOR from snappdf to hosted_ninja seems to fix the issue after running php artisan optimize. I’d rather use snappdf. I believe the bug is still there. Can I give more information to reproduce? There is nothing in the apache error logs.


Are you able to run

./vendor/bin/snappdf download

If the system starts downloading snappdf, it means the binary wasn’t installed after the upgrade


I was able to run that command and it seems to have fixed then issue once I switch back to snappdf in the .env file for PDF_GENERATOR

$ ./vendor/bin/snappdf download
Starting download. Revision: 1079403
Download completed. Extracting the zip archive.
Archive extracted.
Completed! 1079403-Linux_x64 currently in use.
$ php artisan optimize

Looks great! Thanks!