500 Server Error after Upgrade

Original Version: 5.5.21
Attempted Upgrade Version: 5.5.37

Using the built in upgrade mechanism was not working at all. Unfortunately I don’t remember the error but I believe it was related to the change to PHP 8.1. I am running PHP 8.1.11.

When I login, if I put in the wrong 2FA code, it will prompt with that error. When I put in the correct 2FA code, I get a 500: Server Error, and see the following in the logs:

[2022-11-05 17:40:02] production.ERROR: The “–once*” option does not exist. {“exception”:"[object] (Symfony\Component\Console\Exception\RuntimeException(code: 0): The "–once*" option does not exist. at /home//my.domain.com/vendor/symfony/console/Input/ArgvInput.php:220)
#0 /home/
/my.domain.com/vendor/symfony/console/Input/ArgvInput.php(149): Symfony\Component\Console\Input\ArgvInput->addLongOption()
#1 /home//my.domain.com/vendor/symfony/console/Input/ArgvInput.php(82): Symfony\Component\Console\Input\ArgvInput->parseLongOption()
#2 /home/
/my.domain.com/vendor/symfony/console/Input/ArgvInput.php(71): Symfony\Component\Console\Input\ArgvInput->parseToken()
#3 /home//my.domain.com/vendor/symfony/console/Input/Input.php(55): Symfony\Component\Console\Input\ArgvInput->parse()
#4 /home/
/my.domain.com/vendor/symfony/console/Command/Command.php(267): Symfony\Component\Console\Input\Input->bind()
#5 /home//my.domain.com/vendor/laravel/framework/src/Illuminate/Console/Command.php(148): Symfony\Component\Console\Command\Command->run()
#6 /home/
/my.domain.com/vendor/symfony/console/Application.php(1014): Illuminate\Console\Command->run()
#7 /home//my.domain.com/vendor/symfony/console/Application.php(301): Symfony\Component\Console\Application->doRunCommand()
#8 /home/
/my.domain.com/vendor/symfony/console/Application.php(171): Symfony\Component\Console\Application->doRun()
#9 /home//my.domain.com/vendor/laravel/framework/src/Illuminate/Console/Application.php(102): Symfony\Component\Console\Application->run()
#10 /home/
/my.domain.com/vendor/laravel/framework/src/Illuminate/Foundation/Console/Kernel.php(155): Illuminate\Console\Application->run()
#11 /home/*******/my.domain.com/artisan(37): Illuminate\Foundation\Console\Kernel->handle()
#12 {main}

Any suggestions on where to look/what to try?



@david do you have any suggestions?

As a bit of follow up, I tried doing a password reset, and the email was successfully sent out to me so it seems like it’s half working, but I can’t get past the login.


This looks like a combination of two issues.

  1. Your platform is throwing an error as it is not allowing a certain command to run. Is this shared hosting or a VPS/Server?
  2. You are running QUEUE_CONNECTION=sync if you temporarily change to QUEUE_CONNECTION=database (and then refresh the cache) you should get past this.

Hi David.

  1. I’m using CWP Pro as my hosting platform. What command is trying to run so I can see what I need to do to make it happen?

  2. I’m already running with the database setting.


Any other thoughts?


I’ll need to see the full error log as the sample above it clipped.

I don’t think the app is running with the queue enabled as it should never call the a command line like with what we are seeing here.

I had to revert back to my original version since it worked, and I needed to get some entries done.

With the continual and repeated issues I’ve had using Invoice Ninja over the last year, I want to love it, but I can’t. There have been too many issues and problems, and I need something that is much more reliable.