500 error again

Hi, I really love this app after having installed and explored it and I want to fix it and keep using it, but I’m a little nervous now.
I followed the instructions to upload the script via ftp, because of the permissions problem with extracting the zip flder with file manager. It all went well and everything worked, so I started using it. Luckily, I’d only done a couple of invoices, now, I get a 500 error, for whatever reason, I have no idea.

I tried a fresh install with Softalicious via Cpanel, which tolld me the install was successful, but again a 500 error, so I deleted that.

I’m gonna re-upload everything again now. Can I just edit the config file to re-connect to the existing database? If so, which file is it?

Have I just had some bad luck, or is there some wrong setting on my server maybe (Hostgator shared)?



Are there details about the error in storage/logs/laravel-error.log?

Hi Hillel, thanks for taking a look.
I’ve actually done a fresh install now, but I had downloaded a copy of the files. Here’s the last error log.
I guess it would still be useful to find out what to do, in case it happens again.

[2020-08-30 20:11:37] production.ERROR: ErrorException [0] : /home3//public_html/.com/acc/app/Models/Account.php [Line 1126] => Unparenthesized a ? b : c ?: d is deprecated. Use either (a ? b : c) ?: d or a ? b : (c ?: d) {“context”:“PHP”,“user_id”:0,“account_id”:0,“user_name”:"",“method”:“GET”,“user_agent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0”,“locale”:“en”,“ip”:“...”,“count”:19,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”,“url”:"/"} []

Well, I tried to do a fresh install anyway. I got “Whoops someting went wrong”. The database & email test on the install page were sucessful tho. Here’s the error log for this now…

[2020-10-13 09:02:35] production.ERROR: Doctrine\DBAL\Driver\PDOException [1045] : /home3//public_html/.com/ninja/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php [Line 47] => SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO) {“context”:“PHP”,“user_id”:0,“account_id”:0,“user_name”:"",“method”:“POST”,“user_agent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0”,“locale”:“en”,“ip”:“”,“count”:11,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”,“url”:“setup”} []

[2020-10-13 09:02:38] production.ERROR: ErrorException [0] : /home3//public_html/.com/ninja/vendor/symfony/console/Input/ArrayInput.php [Line 135] => Trying to access array offset on value of type int {“context”:“PHP”,“user_id”:0,“account_id”:0,“user_name”:"",“method”:“POST”,“user_agent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0”,“locale”:“en”,“ip”:"...***",“count”:12,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”,“url”:“setup”} []

The first error above is from using PHP 7.4, the v4 app only supports up to PHP 7.3.

Aha! Ok, so I guess that must have caused the failure in this install aswell then.
I’ll try switching to 7.3 and go again.

Thanks again

Will this have overwritten any of the core files?
Just to save me the job or re-uploading everything, if I can just replace for example, the config file and empty the database and start the install again?

I added AddHandler application/x-httpd-php73 .php .php5 to htaccess, but now if I click on public, it’s trying to save the file. The .env file is configured correctly.

Sorry, I don’t understand your question?

So I did a fresh install and now get “Whoops something went wrong”. So now I guess I should start the install process again, which means re-uploading all the files and starting with a clean database.

So, to save me having to re-upload everything again, if I add AddHandler application/x-httpd-php73 .php .php5 to htaccess and delete the .env file, will that allow me to re-start the installation again, or have any other files been modified or created by the installer?


If you’ve changed to PHP 7.3 and are still seeing an error I suggest checking the logs for any new errors.

Ok thanks, this is the latest log.

[2020-10-13 09:14:54] production.ERROR: ErrorException [0] : /home3/####/public_html/####.com/ninja/vendor/symfony/console/Input/ArrayInput.php [Line 135] => Trying to access array offset on value of type int {“context”:“PHP”,“user_id”:0,“account_id”:0,“user_name”:"",“method”:“GET”,“user_agent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0”,“locale”:“en”,“ip”:"#.##.###.#",“count”:1,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”,“url”:“update”} []

I googled "Trying to access array offset on value of type int "
Looks like php version again, so I’m guessing the code in my htaccess is not doing the trick?

Ok, so I set php7.3 for the whole domain and now it’s all working! :slight_smile:

Thanks again for helping me out!

1 Like