3.4 -> 3.6 update - Unable to save CC numbers or Add Credit Card

After upgrading today credit cards are no longer saved to my clients’ portal, nor does it allow it via the “Add credit card” button. It allows entry of data and says successfully added but the portal page doesn’t show it as such.

Very strange, nothing shows up in my error_log and payments do go through they enter manually.

I’m not sure, I’m not able to reproduce the problem.

  • Which payment gateway are you using?
  • What is ‘Token Billing’ set to on /settings/online_payments

Token billing is set to always and has worked very well in 3.4 to store CC information. This is an existing client that used to have a stored CC previously which was deleted before the upgrade. Since upgrade the client cc info won’t store. It’s quite strange.
I attempted to add a test CC # to my test client entry (which used to have a stored CC a while ago that was also removed) and it also didn’t store it. I get the response that it’s been added but it doesn’t.

Finally I created a second new test client and that was able to store the CC number. It seems like it might be related to my existing client entries but not new ones.

Thanks, that’s helpful!

I’ll let you know what I find…

No luck… I tried removing the card then adding another one, it worked correctly.

  • Are you able to reproduce the problem with a new client?
  • Above you wrote “which was deleted before the upgrade”, I just want to check you used the UI and didn’t run SQL queries against the database.

With the new tester client, after I remove the CC # I am not able to re-add it.
It now behaves like the previous clients. Says successfully added but doesn’t show. Perhaps it’s an issue with the token billing? It’s strange that a new client will store it but only once. Had no issue in 3.4 if a client removed a CC and added a new one. Perhaps it’s an issue with my vendor/gateway files? I’m unsure what I should test next.

Was there an increase in the data size from 3.4-3.6? Looks like my ninja folder is 100mb larger than previously (about 300mb before now about 400mbs). perhaps some lingering files were left over when the new zip was extracted and overwritten.

Should I consider doing a clean install while retaining my custom images, sql database and env file? What else would I need to move over in a clean install?

To add (since I can’t edit old posts) I haven’t made any changes to clients or data within SQL. I’ve only made changes from within the invoice ninja online portal. I tried removing my custom CSS (just color stuff) and it made no difference. I looked on my payment gateway and had an interesting result when looking at the transactions.

The clients without payment stored are also not being stored on my payment gateway. To add to that transactions since the update to 3.6 that didn’t save the CC info (set to default to always save CC info) don’t store in the CC info but state that the CVV response and AVS (address) along with postal code match. Where are the ones that have stored their CC info (and just choose to use CC info on file) state the CVV and AVS info was not provided (both situations have address and CVV fields to fill out originally and are required). To add I do not have CVV or AVS set to required in processing options via my payment gateway (I have a small core group of clients, not worried about fraud from them). I also have card verification for storage of CC info on my payment gateway set to off.

I really believe this is an issue with the vendor setup. Has anything been changed in the provided vendor setups for 3.6? Orders are still going through with the clients putting in their info manually but storing CC on my payment gateway is obviously a big deal to me so i would like to find a resolution obviously.

Most of the additional size is from mpdf which was added to support exporting reports to PDF.

Which payment gateway are you using?


It looks like the vendor folder went from 98mb to 219mb. But I see nothing was changed for Braintree though either through OmniPay or the Braintree folder itself. It looks like it’s not able to push the data to braintree or perhaps link up the user? Clicking on “view in braintree” does take me to the right client page though.

This is a real headscratcher.

Thanks, I was testing with Stripe.

Here’s the fix, you just need to move the $data line up. It will be included with our next release.


Awesome! That fixed it! I also added the other edits including the space below $data line at 103(not sure if it was needed but seems to be working without a hitch).

Thanks for your help and continued development.

Great to hear, thanks for letting us know!