Zapier with Hosted V5

I have a hosted account on V5, when trying to connect Zapier I get the error:
Authentication failed: Your API token is not valid, please check the value in Invoice Ninja on /settings/api_tokens.

I feel like the Zapier wizard is trying to force the connection to use the old rather than the
I was attempting to make a API Token, but I don’t know the correct URL to use. Can anyone give me any guidance on this? Thanks in advance.


You can create a token in v5 on Settings > Account Management, the settings search is a great way to find these things in v5.

Hey Hillel,
Thanks for the reply. I was able to make an API, but Zapier only seems to want to connect to the V4 version of Invoice Ninja. I took a screenshot of the Zapier wizard. I tried adding my API Token, but I only get the response “authentication failed: Your API token is not valid, please check the value in Invoice Ninja on /settings/api_tokens.” which seems to also indicate it’s trying to connect to the V4 version, not the V5 version.

It’s looking more and more likely the Zapier process needs to be updated to use the v5 settings. Any other thoghts?

You can use this link to join Zapier v5:

If you search for “Invoice Ninja” you should see the v5 version

I use that link, with the same result. When I try to search for Invoice Ninja I only get/see the V4 Version.

I’m not sure, you may want to ask Zapier for advice.

Yea, I’ve asked for advise there too. It appears they think it’s a issue with Invoice Ninja, while Invoice Ninja seems to think its a issue with Zapier. Just to clear it up, when you do a search on their site do you see “Invoice ninja V5” ? I only see one result pop-up, when I click it I get the same popup window I attached before.

Either way, I appreciate your help on this.

Did you click the ‘Accept’ button on the link above?

Note: when I search I need to scroll to the bottom to see the 5.0.7 version

I did click the accept button. Maybe it’s because I have a free version of Zapier I can’t see the 5.0.7 version…

Here’s what I see when searching apps.

The link I’m using is

Yes!! Somehow that allowed me to find the 5.0.7 icon! Tested and working!!! Thank you so much!