Yet Another Mixed Content / Redirect Loop Issue

Hi Hillel,

I have a great self-hosted and white-labled Invoice Ninja 3.9.2 installation for a couple of years now, I love it!

It still works great, but only inside my network, outside the network I get mixed content where the page only partially loads without formatting and unable to log in. I am not sure when the issue started since clients generally use the attached PDF invoices anyway.

Things I have tried but have not worked:

In the main ENV:
-If I set REQUIRE_HTTPS=true, but it goes into redirect loop.
-SESSION_ENCRYPT=true and SESSION_SECURE=true have no effect.
-I have TRUSTED_PROXIES set to (which I have to have for MacOS X server 5.3 because of its proxy)
-Since I run it as a virtual host subdomain i.e. , I have uncommented the required line in the public folder’s ENV (but this has no effect anyway)

Any ideas why work inside my network and not out?

Thanks in Advance!

Maybe the info here will help:

Thanks for reply, I saw that link before, my server runs Apache, so still no solution yet. What confounds me is that invoice ninja is working perfectly, BUT only behind my router.

New but related, when I load the url from a computer outside my network, is redirected or loads “invoice.mynetwork.comlogin” without the slash between com and login with results in a server not found. If I add the slash, it loads normally but with the same mixed content issue. Not sure if I messed up something looking for a solution.

Any more suggestions?

Sorry, it definitely sounds like a web serve configuration issue.

This is outside my area of expertise, maybe someone else has advice?