V4 to v5 migration: PDF generation is not working


after migrating from v4 to v5 the PDF generation did not work anymore (Neither with snappdf nor with PhantomJS).
After some digging around I deleted the data of the column custom_fields in the table companies for the migrated company. After this it worked again.

It seems like the json data has changed and this is not migrated correctly so that the PDF generation fails.

Can you please have a look into this and fix it if possible?


Did you migrate using the latest version?

cc @david

Yes, v4 is the latest,v5 was on .15

I suggest retrying with the latest v4 and v5, currently v4.5.43 and v5.2.17.

Tried that, too => same result.

The problem seems to be the custom_fields.
In v4 it is like this:
{"client1":"Lieferantennummer","invoice_text1":"Delivery Date\/Lieferdatum","invoice1":"Delivery Date\/Lieferdatum"}
In v5 it looks different:
{"company1":"","client1":"Lieferantennummer|single_line_text","invoice1":"Delivery Date\\Lieferdatum|date"}