Upload File not working on Invoice

Hello there,

I just updated to the latest version yesterday (v5.2.18) and now the Upload option doesn’t work when trying to add documents to an invoice. I have used this before without issue, but today it glows slightly on pressing the button, but then nothing happens. Nothing specific that I can see in the logfile as far as an error.

Anyone else seen something simliar?



As a follow up to this, I’ve noticed that the Upload File option is no longer working anywhere within Invoice Ninja. If I try upload a document to a customer account, the same thing happens as noted above.

Tried this on my iPhone using the v5 app. I can take a picture and successfully add it to the documents tab, but the file upload here also does not work.

Sorry for the trouble, this should be resolved in the next version.

1 Like

Thanks for the quick reply. :slight_smile:

Not sure if this was to be fixed in v5.2.19, however I just updated to .19 and the Upload button is still not working as expected.

It’s possible it missed the cutoff for the .19 build, please let us know if you still see the problem in .20.

1 Like

Will do. Thank you.


Hi, Im still having this issue on 5.3.8. Works if I visit the site, but not in ios and windows apps.

The next version of the Windows app should support it.

Which version of the iOS app are you using?

Ok great :blush:

iOS version V1.1

On iOS does the app fail to both take a picture and select a file?

Can you check the app has the permissions enabled.