Update Failing FormatException:

updating from 5.3.91 to 5.4.3 consistently delivers the following error:

FormatException: Unexpected end of input (at character 1)


Health Check returns all green checks…
any suggestions?


It may help to increase the server’s PHP memory limit.

I changed the PHP memory limit from 256 to 512mb
I no longer get the FormatException error, it just says “Server Error” when I try to upgrade it now.
considering raising the max script time from 300, but I thought I’d see if you had any other ideas first.

I also tried to unpack the latest version and copy the .env file that didn’t work either…
only gives me the “hourglass” when I try to run it.

Thank you for your input

Are there any details about the 500 error in storage/logs?

Which version of PHP are you using?

Using PHP 7.4 system will support up to 8.1
I boosted the Max_execution_time to 600, same results…
Ran php artisan optimize, checks all successful
No entries in the storage/logs after upgrade attempt.

Please try increasing the PHP memory limit, not max execution time.

When I did this it stopped giving me the Format Exception error, so I think it helped… but it just turned into a generic “Server Error”

I thought I had done a “manual install” with a previous update package, just extracting the files into the directory, then copying the .env file and resetting the logo. But that doesn’t seem to work this time. I just get the forever hourglass…

Are there any errors in the web server error logs or storage/logs?

@david do you have any thoughts?

No errors were logged…


You’ll want to set APP_DEBUG=true in your .env file and then optimize, this should force the error reporting on your system, when you get the error message from storage/logs/laravel.log let us know the contents.

Applied APP_DEBUG=true
ran update, and resulted in the following :

the error.log file contained the following: ( I did alter the directory name for posting here)

[22-Jun-2022 21:25:02 America/New_York] PHP Fatal error: Uncaught Error: Class ‘ComposerAutoloaderInit699f7a8fa5341bceb22d9bb8021a4ff5’ not found in /home/invoice.ninja/vendor/autoload.php:12
Stack trace:
#0 /home/invoice.ninja/artisan(18): require()
#1 {main}
thrown in /home/invoice.ninja/vendor/autoload.php on line 12
[22-Jun-2022 21:25:02 America/New_York] PHP Fatal error: Uncaught Error: Class ‘ComposerAutoloaderInit699f7a8fa5341bceb22d9bb8021a4ff5’ not found in /home/invoice.ninja/vendor/autoload.php:12
Stack trace:
#0 /home/invoice.ninja/artisan(18): require()
#1 {main}
thrown in /home/invoice.ninja/vendor/autoload.php on line 12

Thank you for your attention in this matter, appreciate the help

@david I am sure you have plenty to do, please let me know if you see any issues with the above error log when you have a moment :slight_smile: I would like to get this update installed


There are a couple of things going on here i think.

The system is trying to perform all migrations again, which may indicate your migrations table has been modified.

The second issue is the autoloader… to resolve this particular issue you should clear the contents of bootstrap/cache.

cleared the files in bootstrap/cache
attempted to upgrade… same result… “Server Error”
reactivated debug mode… same error result from previous post.
The error text was from the error_log file in the root directory, the storage/logs/laravel.log had nothing new added after the failed update.