Update error - Too few arguments to function Illuminate...AuthService...

Maybe anyone can help?

[Symfony\Component\Debug\Exception\FatalThrowableError]
Type error: Too few arguments to function Illuminate\Foundation\Support\Providers\AuthServiceProvider::registerPolicies(), 0 passed in /var/www/clients/client0/web5/web/app/Providers/AuthServiceProvider.php on line 52 and exactly
1 expected

The laravel error log says:

[2018-01-10 18:50:52] production.ERROR: Symfony\Component\Debug\Exception\FatalThrowableError [0] : /var/www/clients/client0/web5/web/bootstrap/cache/compiled.php [Line 5734] => Type error: Too few arguments to function Illuminate\Foundation\Support\Providers\AuthServiceProvider::registerPolicies(), 0 passed in /var/www/clients/client0/web5/web/app/Providers/AuthServiceProvider.php on line 52 and exactly 1 expected {“context”:“PHP”,“user_id”:0,“account_id”:0,“user_name”:"",“method”:“GET”,“url”:“https://domain.tld”,“previous”:“https://domain.tld”,“user_agent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/604.4.7 (KHTML, like Gecko) Version/11.0.2 Safari/604.4.7”,“ip”:“78.54.74.21”,“count”:1,“is_console”:“no”,“is_api”:“no”,“db_server”:“mysql”} []

Any idea what to change?

And:

[Wed Jan 10 20:05:18.198158 2018] [proxy_fcgi:error] [pid 16669] [client 192.168.1.1:55074] AH01071: Got error ‘PHP message: PHP Warning: Declaration of App\Providers\EventServiceProvider::boot() should be compatible with Illuminate\Foundation\Support\Providers\EventServiceProvider::boot(Illuminate\Contracts\Events\Dispatcher $events) in /var/www/clients/client0/web5/web/bootstrap/cache/compiled.php on line 17821\nPHP message: PHP Warning: Declaration of App\Providers\RouteServiceProvider::boot() should be compatible with Illuminate\Foundation\Support\Providers\RouteServiceProvider::boot(Illuminate\Routing\Router $router) in /var/www/clients/client0/web5/web/bootstrap/cache/compiled.php on line 17851\n’

I got no update or upload errors,

If you got the code from GitHub did you run composer install

I have downloaded the code from your site and then uploaded via ftp.

(downloads.invoiceninja.org)

Invoiceninja was running before, so I tried to update/upgrade. Afterwards this/these errors occured.

If you have SSH access it may help to run composer dump-autoload

Can you repost the /update errors, I don’t see them.

composer dump-autoload has been processed, the errors with debug enabled is here:

https://d.pr/i/M4lAYf

(hope it is okay to send a screenshot?)

In plain text:

[Symfony\Component\Debug\Exception\FatalThrowableError]
Type error: Too few arguments to function Illuminate\Foundation\Support
Providers\AuthServiceProvider::registerPolicies(), 0 passed in /var/www/clients/
client0/web5/web/app/Providers/AuthServiceProvider.php on line 52 and exactly
1 expected

Try emptying the bootstrap/cache/ folder

Seems that has helped - awesome!

You rock!

Great to hear!