Update doesn't work anymore

Hi,

I used to have a small icon where it tells me when a new version was out.
Now the only way I can make it work is doing a force update.

In the info icon → Force update, it tells me my current version is 5.2.7 and the latest is 5.1.60.

Thanks for the help to fix it.
Capture

Hi,

Are the crons running?

@david any other thoughts on what may cause this?

The cron job is setup.
If it wasn’t I would have gotten some sort of error message, no ?

If the cron isn’t running you’ll see a red triangle in the bottom left corner

No error indication.
I dont know if it’s related, but here is console output, when i try to save a setting.

Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist. /#/:1
PUT https://invoice.comp.local/api/v1/companies/VolejRejNm? 500 main.foss.dart.js?v=5.2.7:72399

Are there any details about the 500 error in the logs in storage/logs/

No error messages in laravel.log.

I think I understand what is happening here. I’ll come back with a fix.

@raziel00

Can you test something please.

in config/ninja.php

edit the line

    'app_tag' => '5.2.7-release',

and change to

    'app_tag' => '5.2.7',

Afterwards run php artisan optimize or (/update?secret=) and then try the upgrade again.

Hi,

Ok, edited the line, ran php artisan optimize then went to force update.
It’s the same result and the line goes back the way it was.