Underpayment not working desktop app

It seems like I can’t underpay invoices anymore on the hosted desktop app (Linux). I think It was still working last week, but I won’t bet my life on it. Here the scenario :

  • create an invoice
  • enter a payment for a fraction of the amount
  • get this error 422: The given data was invalid. Amounts do not balance correctly.

I double checked my payment parameters : underpayment is allowed and min underpayment is 0. Same behavior on mobile app.

That’s annoying. Do you have any idea on how to avoid this ? Am I missing something ? Thanks!


The under payment settings are for clients paying in the client portal, they don’t affect the admin portal.

From the error it sounds like you may be setting a value for the payment and for the specific invoice.

Note: the payment amount field can be hidden by disabling the “apply payments later” option in the payment settings.

OK, I think I understand, thank you. It seems a bit weird to me. If I understood well, on a 300€ invoice, I can’t create a 150€ payment if the “apply payment” later is activated ?

  • Sometimes a customer pays two invoices with the same bank transfert or credit card transaction. In that case, the “apply payment later” is a great option : record the payment, first, apply it on each individual invoice. A good improvement comparing to v4.
  • Sometimes a customer pays a single invoice half in cash, half using a credit card. In that case I get this 442 error. Should I enter the two payments and then apply them ? Because recording a payment the simple way return the 442 error.

You can, you’d just need to leave the amount field blank. From the error I assume you set a value in the field.

  • For this case you can create a payment for both invoice at the same time.

  • For this you’d want to create two payments. For the first payment you’d need to change the amount set for the invoice to half of the amount.

You only need to set a value for the top amount field if the payment is more than the invoice amount.

Thank you Hillel, that’s perfectly clear now. The display of two amount fields was confusing to me. Cheers! [Edit bad spelling]

1 Like